Tests whether the effect instance is appropriate for the given vertex format.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public bool MatchesFormat( VertexFormat vertexFormat ) |
Visual Basic |
---|
Public Function MatchesFormat ( _ vertexFormat As VertexFormat _ ) As Boolean |
Visual C++ |
---|
public: bool MatchesFormat( VertexFormat^ vertexFormat ) |
Parameters
- vertexFormat
- Type: Autodesk.Revit.DB.DirectContext3D..::..VertexFormat
A vertex format.
Return Value
True if the effect instance is valid for use with the specified vertex format.
Remarks
The vertex format may define vertex data that are not used by the effect instance. However, the effect
instance can not reference vertex data that do not exist in the vertex format.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |