Tests whether this curve element and the input curve element have common tangent join at the given end-point.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2017
Syntax
C# |
---|
public bool HasTangentJoin(
int end,
ElementId other
) |
Visual Basic |
---|
Public Function HasTangentJoin ( _
end As Integer, _
other As ElementId _
) As Boolean |
Visual C++ |
---|
public:
bool HasTangentJoin(
int end,
ElementId^ other
) |
Parameters
- end
- Type: System..::..Int32
Index of one of the curve's end. Values '0' and '1' indicate the start or end point, respectively.
- other
- Type: Autodesk.Revit.DB..::..ElementId
ElementId of another Curve Element from the same document.
Return Value
Returns True if the two curve elements have a tangent join at the given end-point.
Exceptions
See Also