Gets References to the faces that the MassSurfaceData provides properties for.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public IList<Reference> GetFaceReferences() |
Visual Basic |
---|
Public Function GetFaceReferences As IList(Of Reference) |
Visual C++ |
---|
public: IList<Reference^>^ GetFaceReferences() |
Return Value
Returns an array of References to Faces that the MassSurfaceData provides properties for.
Remarks
The results are always references to Faces. The Reference Type should be REFERENCE_TYPE_SURFACE.
Currently Revit improperly reports it as REFERENCE_TYPE_NONE.