Checks whether or not the massing and site tools are enabled, and enable or disable them.
Namespace: Autodesk.Revit.ApplicationServicesAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public bool IsMassingEnabled { get; set; } |
Visual Basic |
---|
Public Property IsMassingEnabled As Boolean Get Set |
Visual C++ |
---|
public: property bool IsMassingEnabled { bool get (); void set (bool value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled. |