Set the string value of a family parameter of the current family type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void SetValueString( FamilyParameter familyParameter, string value ) |
Visual Basic |
---|
Public Sub SetValueString ( _ familyParameter As FamilyParameter, _ value As String _ ) |
Visual C++ |
---|
public: void SetValueString( FamilyParameter^ familyParameter, String^ value ) |
Parameters
- familyParameter
- Type: Autodesk.Revit.DB..::..FamilyParameter
The family parameter of current type.
- value
- Type: System..::..String
The new value string for family parameter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter" or "value"-is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter. or the input argument-"value"-is an illegal string. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family parameter is determined by formula, or it is not a value type, or the current family type is invalid. |