Sets graphic overrides for an element in the view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public void SetElementOverrides( ElementId elementId, OverrideGraphicSettings overrideGraphicSettings ) |
Visual Basic |
---|
Public Sub SetElementOverrides ( _ elementId As ElementId, _ overrideGraphicSettings As OverrideGraphicSettings _ ) |
Visual C++ |
---|
public: void SetElementOverrides( ElementId^ elementId, OverrideGraphicSettings^ overrideGraphicSettings ) |
Parameters
- elementId
- Type: Autodesk.Revit.DB..::..ElementId
Element to override.
- overrideGraphicSettings
- Type: Autodesk.Revit.DB..::..OverrideGraphicSettings
An object representing all graphic overrides of the element in view.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | elementId is not a valid Element identifier. -or- Fill pattern must be a drafting pattern. -or- Fill pattern Id must be invalidElementId or point to a LinePattern element. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | View does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes. |