Fabrication body connector Id.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public int BodyConnectorId { get; set; } |
Visual Basic |
---|
Public Property BodyConnectorId As Integer Get Set |
Visual C++ |
---|
public: property int BodyConnectorId { int get (); void set (int value); } |
Remarks
A reference to the fabrication configuration connectors.
Setting the connector value will also set the connector lock.
A value of 0 indicates the connector is set to none.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: bodyConnectorId is invalid based on the shape and domain. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: the connector cannot be modified on an owned fabrication part. -or- When setting this property: the connector is already connected. -or- When setting this property: the fabrication part is connected to more than one item. |