Fixity of rotation around Z.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public AnalyticalFixityState RotationZ { get; set; } |
Visual Basic |
---|
Public Property RotationZ As AnalyticalFixityState Get Set |
Visual C++ |
---|
public: property AnalyticalFixityState RotationZ { AnalyticalFixityState get (); void set (AnalyticalFixityState value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The fixity state rotationZ is not valid for Analytical Link Type parameters. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural. |