Returns the ViewSection id for the index of the ElevationMarker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2013

Syntax

C#
public ElementId GetViewId(
	int index
)
Visual Basic
Public Function GetViewId ( _
	index As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetViewId(
	int index
)

Parameters

index
Type: System..::..Int32
The index of the ElevationMarker for which a ViewSection id will be returned.

Return Value

ViewSection id of the view at the ElevationMarker index, invalid element id otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException The index index is out of range for this ElevationMarker.

See Also