Checks if value is almost zero, using the internal tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2021

Syntax

C#
public static bool IsAlmostZero(
	double value
)
Visual Basic
Public Shared Function IsAlmostZero ( _
	value As Double _
) As Boolean
Visual C++
public:
static bool IsAlmostZero(
	double value
)

Parameters

value
Type: System..::..Double
The value to check.

Return Value

True if value is almost zero, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException The given value for value is not finite

See Also