A value to indicate the status of an external resource load operation. IExternalResourceServers
should set this in the LoadResource() method.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public ExternalResourceLoadStatus LoadStatus { get; set; } |
Visual Basic |
---|
Public Property LoadStatus As ExternalResourceLoadStatus Get Set |
Visual C++ |
---|
public: property ExternalResourceLoadStatus LoadStatus { ExternalResourceLoadStatus get (); void set (ExternalResourceLoadStatus value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The ExternalResourceLoadContent does not contain all the necessary data. To see the requirements for this particular resource type, please see the documentation for the specific subclass of ExternalResourceLoadContent. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |