Checks whether the link with this id is loaded.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static bool IsLoaded( Document document, ElementId typeId ) |
Visual Basic |
---|
Public Shared Function IsLoaded ( _ document As Document, _ typeId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: static bool IsLoaded( Document^ document, ElementId^ typeId ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
A document. Revit will see if typeId corresponds to a loaded link in this document.
- typeId
- Type: Autodesk.Revit.DB..::..ElementId
An element id. Revit will check if typeId corresponds to a loaded link in the given document.
Return Value
True if typeId corresponds to a loaded RevitLinkType. False otherwise.
Remarks
Returns false if typeId is not the id of a RevitLinkType.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |