Checks if given type is valid flexible duct type.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static bool IsFlexDuctTypeId( Document document, ElementId ductTypeId ) |
Visual Basic |
---|
Public Shared Function IsFlexDuctTypeId ( _ document As Document, _ ductTypeId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: static bool IsFlexDuctTypeId( Document^ document, ElementId^ ductTypeId ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document.
- ductTypeId
- Type: Autodesk.Revit.DB..::..ElementId
ElementId of the flexible duct type to check.
Return Value
True if flexible duct type can used for this duct, false otherwise.
Remarks
A type is valid for flexible duct if it can be used to the flexible duct element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |