The type of HVAC system used by the building for conceptual model energy calculations.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public gbXMLBuildingHVACSystem BuildingHVACSystem { get; set; } |
Visual Basic |
---|
Public Property BuildingHVACSystem As gbXMLBuildingHVACSystem Get Set |
Visual C++ |
---|
public: property gbXMLBuildingHVACSystem BuildingHVACSystem { gbXMLBuildingHVACSystem get (); void set (gbXMLBuildingHVACSystem value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The building HVAC system does not fall within an appropriate range. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |