Represents the types of results available for calculating the intersection between a solid and a curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public enum SolidCurveIntersectionMode |
Visual Basic |
---|
Public Enumeration SolidCurveIntersectionMode |
Visual C++ |
---|
public enum class SolidCurveIntersectionMode |
Members
Member name | Description |
---|---|
CurveSegmentsInside | The results will include only curve segments inside the solid volume. This also will include curve segments coincident with the face(s) of the volume. |
CurveSegmentsOutside | The results will include only curve segments outside the solid volume. |