The detail level of this view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public ViewDetailLevel DetailLevel { get; set; } |
Visual Basic |
---|
Public Property DetailLevel As ViewDetailLevel Get Set |
Visual C++ |
---|
public: property ViewDetailLevel DetailLevel { ViewDetailLevel get (); void set (ViewDetailLevel value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: Cannot set ViewDetailLevel to Unassigned |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: View does not have a Detail Level property -or- When setting this property: Detail Level cannot be modified. |