Constructs a new instance of a filter to match families by structural material type,
with the option to match all families which are not of the given structural material type.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public FamilyStructuralMaterialTypeFilter( StructuralMaterialType structuralMaterialType, bool inverted ) |
Visual Basic |
---|
Public Sub New ( _ structuralMaterialType As StructuralMaterialType, _ inverted As Boolean _ ) |
Visual C++ |
---|
public: FamilyStructuralMaterialTypeFilter( StructuralMaterialType structuralMaterialType, bool inverted ) |
Parameters
- structuralMaterialType
- Type: Autodesk.Revit.DB.Structure..::..StructuralMaterialType
The structural material type to match.
- inverted
- Type: System..::..Boolean
True if the filter should match all families which are not of the given structural material type.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |