Gets the ids of the RebarShapes elements that defines the shapes of the rebar.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2019
Syntax
C# |
---|
public IList<ElementId> GetAllRebarShapeIds() |
Visual Basic |
---|
Public Function GetAllRebarShapeIds As IList(Of ElementId) |
Visual C++ |
---|
public: IList<ElementId^>^ GetAllRebarShapeIds() |
Return Value
Returns the ids of the RebarShapes elements that defines the shapes of the rebar.
Remarks
If multiple bars in the set has the same shape id, this id will be reported only one in the resulted array.