Forces the elements in the Revit document to automatically join to their neighbors where appropriate.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void AutoJoinElements() |
Visual Basic |
---|
Public Sub AutoJoinElements |
Visual C++ |
---|
public: void AutoJoinElements() |
Remarks
Use this method to force elements in the document to automatically join to their neighbors. Note that when a transaction
is committed there is an automatic call to automatically join elements.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..AutoJoinFailedException | Thrown when the operation fails. |