Provides access to settings that control Revit's Text Editor appearance and functionality.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public class TextEditorOptions : IDisposable |
Visual Basic |
---|
Public Class TextEditorOptions _ Implements IDisposable |
Visual C++ |
---|
public ref class TextEditorOptions : IDisposable |
Remarks
These settings are stored in the Revit.ini file. All documents in Revit instances which use this Revit.ini will follow these settings.
Examples

public void SetEditorOptions() { TextEditorOptions editorOptions = TextEditorOptions.GetTextEditorOptions(); editorOptions.ShowBorder = false; editorOptions.ShowOpaqueBackground = true; }

Public Sub SetEditorOptions() Dim editorOptions As TextEditorOptions = TextEditorOptions.GetTextEditorOptions() editorOptions.ShowBorder = False editorOptions.ShowOpaqueBackground = True End Sub
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.UI..::..TextEditorOptions
Autodesk.Revit.UI..::..TextEditorOptions