Checks whether the element type id is valid for the give DefaultElmentType id.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public bool IsDefaultElementTypeIdValid( ElementTypeGroup defaultTypeId, ElementId typeId ) |
Visual Basic |
---|
Public Function IsDefaultElementTypeIdValid ( _ defaultTypeId As ElementTypeGroup, _ typeId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: bool IsDefaultElementTypeIdValid( ElementTypeGroup defaultTypeId, ElementId^ typeId ) |
Parameters
- defaultTypeId
- Type: Autodesk.Revit.DB..::..ElementTypeGroup
The default element type id.
- typeId
- Type: Autodesk.Revit.DB..::..ElementId
The element type id.
Return Value
True if the element type id is valid for the give DefaultElmentType id, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |