Sets the Young's modulus of the asset.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void SetYoungModulus( double youngModulus ) |
Visual Basic |
---|
Public Sub SetYoungModulus ( _ youngModulus As Double _ ) |
Visual C++ |
---|
public: void SetYoungModulus( double youngModulus ) |
Parameters
- youngModulus
- Type: System..::..Double
Remarks
The Young's modulus is one-dimensional for wood-based and isotropic materials.
This method sets the x, y, and z components to the same value.
The value is in Newtons per foot meter (N/(ft · m)).