Set the list of extra options to be passed into the importer. Each entry in the map is a pair of option name and value.
Note that any value here will overwrite the other values in the IFCImportOptions, if it has the same name.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2018.1
Syntax
C# |
---|
public void SetExtraOptions(
IDictionary<string, string> options
) |
Visual Basic |
---|
Public Sub SetExtraOptions ( _
options As IDictionary(Of String, String) _
) |
Visual C++ |
---|
public:
void SetExtraOptions(
IDictionary<String^, String^>^ options
) |
Parameters
- options
- Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The list of options.
Exceptions
See Also