The number of pieces of mechanical equipment operating in parallel at any given time.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2019
Syntax
C# |
---|
public int OnDuty { get; set; } |
Visual Basic |
---|
Public Property OnDuty As Integer
Get
Set |
Visual C++ |
---|
public:
property int OnDuty {
int get ();
void set (int value);
} |
Exceptions
Exception | Condition |
---|
Autodesk.Revit.Exceptions..::..ArgumentException |
When setting this property: The number of on duty (number) must be less than or equal to the number of available equipments or there should be at least one equipment on duty.
|
See Also