Sets the release type.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public void SetReleaseType( bool start, ReleaseType releaseType ) |
Visual Basic |
---|
Public Sub SetReleaseType ( _ start As Boolean, _ releaseType As ReleaseType _ ) |
Visual C++ |
---|
public: void SetReleaseType( bool start, ReleaseType releaseType ) |
Parameters
- start
- Type: System..::..Boolean
The position on analytical model stick element. True for start, false for end.
- releaseType
- Type: Autodesk.Revit.DB.Structure..::..ReleaseType
The type of release.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |