Deactivates the given temporary mode.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016 Subscription Update
Syntax
C# |
---|
public void DeactivateMode( TemporaryViewMode mode ) |
Visual Basic |
---|
Public Sub DeactivateMode ( _ mode As TemporaryViewMode _ ) |
Visual C++ |
---|
public: void DeactivateMode( TemporaryViewMode mode ) |
Parameters
- mode
- Type: Autodesk.Revit.DB..::..TemporaryViewMode
The mode to deactivate
Remarks
The method has no effect on modes that are already deactivated.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The temporary mode is not available in the associated view. The view is either of a type that does not support this mode, or is currently in a context that makes the mode presently inapplicable. -or- The temporary mode is presently not enabled in the associated view. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |