Returns an object that represents the compound structure of the element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public CompoundStructure GetCompoundStructure() |
Visual Basic |
---|
Public Function GetCompoundStructure As CompoundStructure |
Visual C++ |
---|
public: CompoundStructure^ GetCompoundStructure() |
Remarks
A copy of the compound structure is returned and changes made to it will not apply to the type until SetCompoundStructure is called.
From this object the layers of a compound structure can be accessed. If the element does
not have a compound structure then this method will return nullNothingnullptra null reference (Nothing in Visual Basic).