Returns the current rendering settings for this 3d view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public RenderingSettings GetRenderingSettings() |
Visual Basic |
---|
Public Function GetRenderingSettings As RenderingSettings |
Visual C++ |
---|
public: RenderingSettings^ GetRenderingSettings() |
Return Value
The returned object represents the current rendering settings. If you change the returned object, you need to call SetRenderingSettings to apply the new settings back to Revit.
Examples

public RenderingSettings GetFirstRenderingSettings(Document document) { // RenderingSettings isn't used to support family document. if (document.IsFamilyDocument) return null; // Get 3d view List<View3D> theView3Ds = new List<View3D>(); foreach (View3D view3D in RetrieveElementByType<View3D>(document)) { // It's strongly recommend to get RenderingSettings from visible 3d view, // although it can retrieve data from an invisible one, if (view3D.IsTemplate || !view3D.CanBePrinted) continue; return view3D.GetRenderingSettings(); } return null; } public static List<T> RetrieveElementByType<T>(Document document) where T : Autodesk.Revit.DB.Element { FilteredElementCollector collector = new FilteredElementCollector(document); return collector.OfClass(typeof(T)).Cast<T>().ToList<T>(); }

Public Function GetFirstRenderingSettings(document As Document) As RenderingSettings ' RenderingSettings isn't used to support family document. If document.IsFamilyDocument Then Return Nothing End If ' Get 3d view Dim theView3Ds As New List(Of View3D)() For Each view3D As View3D In RetrieveElementByType(Of View3D)(document) ' It's strongly recommend to get RenderingSettings from visible 3d view, ' although it can retrieve data from an invisible one, If view3D.IsTemplate OrElse Not view3D.CanBePrinted Then Continue For End If Return view3D.GetRenderingSettings() Next Return Nothing End Function Public Shared Function RetrieveElementByType(Of T As Autodesk.Revit.DB.Element)(document As Document) As List(Of T) Dim collector As New FilteredElementCollector(document) Return collector.OfClass(GetType(T)).Cast(Of T)().ToList() End Function