Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public FamilyInstanceCreationData(
	Curve curve,
	FamilySymbol symbol,
	Level level,
	StructuralType structuralType
)
Visual Basic
Public Sub New ( _
	curve As Curve, _
	symbol As FamilySymbol, _
	level As Level, _
	structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
	Curve^ curve, 
	FamilySymbol^ symbol, 
	Level^ level, 
	StructuralType structuralType
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The curve where the instance is based.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.DB..::..Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

See Also