Sets the rendering asset for the appearance asset element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public void SetRenderingAsset( Asset asset ) |
Visual Basic |
---|
Public Sub SetRenderingAsset ( _ asset As Asset _ ) |
Visual C++ |
---|
public: void SetRenderingAsset( Asset^ asset ) |
Parameters
- asset
- Type: Autodesk.Revit.DB.Visual..::..Asset
The new rendering asset. It should be an appearance asset.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The asset is not an appearance asset. |