Validates curve to be added to the wireframe shape being constructed. Used by addCurve to validate input.
This function may be used to pre-validate the geometry being added to avoid an exception from AddCurve().
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2016
Syntax
C# |
---|
public static bool ValidateCurve(
Curve GCurve
) |
Visual Basic |
---|
Public Shared Function ValidateCurve ( _
GCurve As Curve _
) As Boolean |
Visual C++ |
---|
public:
static bool ValidateCurve(
Curve^ GCurve
) |
Return Value
True is %GCurve% is acceptable as a part of a wireframe shape representation being built.
Exceptions
See Also