Identifies if the iteration has completed.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public virtual bool IsDone() |
Visual Basic |
---|
Public Overridable Function IsDone As Boolean |
Visual C++ |
---|
public: virtual bool IsDone() |
Return Value
True if the iteration has no more matching worksets. False if there are more workset ids to be iterated.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator. |