Assigns if a layer is included in wrapping at inserts and ends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public void SetParticipatesInWrapping(
	int layerIdx,
	bool participatesInWrapping
)
Visual Basic
Public Sub SetParticipatesInWrapping ( _
	layerIdx As Integer, _
	participatesInWrapping As Boolean _
)
Visual C++
public:
void SetParticipatesInWrapping(
	int layerIdx, 
	bool participatesInWrapping
)

Parameters

layerIdx
Type: System..::..Int32
The index of the layer.
participatesInWrapping
Type: System..::..Boolean
True if the specified layer will participate in wrapping at inserts and ends, false otherwise.

Remarks

This method applies only to interior and exterior shell layers.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException The wrapping of the layer is not valid.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException The layer index is out of range.

See Also