Gets the centerline of the bearer. The method is applicable only for bearer hanger.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public Line GetBearerCenterline() |
Visual Basic |
---|
Public Function GetBearerCenterline As Line |
Visual C++ |
---|
public: Line^ GetBearerCenterline() |
Return Value
The centerline of the bearer.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | The hanger is not a bearer hanger. |