Gets the subelement referenced by a unique id string.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public Subelement GetSubelement( string uniqueId ) |
Visual Basic |
---|
Public Function GetSubelement ( _ uniqueId As String _ ) As Subelement |
Visual C++ |
---|
public: Subelement^ GetSubelement( String^ uniqueId ) |
Parameters
- uniqueId
- Type: System..::..String
The unique id that identifies element or subelement.- UniqueId
Return Value
The subelement referenced by the input argument.
Remarks
nullNothingnullptra null reference (Nothing in Visual Basic) will be returned if the input id string doesn't reference to a valid element or subelement.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |