The placement type to be used if prompting to place an instance of a face-based family. This option is ignored if placing a non-face-based family. If placing a face-based family, Default is an acceptable value, but will correspond to the first available selection in the user interface.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2017

Syntax

C#
public FaceBasedPlacementType FaceBasedPlacementType { get; set; }
Visual Basic
Public Property FaceBasedPlacementType As FaceBasedPlacementType
	Get
	Set
Visual C++
public:
property FaceBasedPlacementType FaceBasedPlacementType {
	FaceBasedPlacementType get ();
	void set (FaceBasedPlacementType value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also