Create a new RibbonPanel on the Add-Ins tab.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public virtual RibbonPanel CreateRibbonPanel( string panelName ) |
Visual Basic |
---|
Public Overridable Function CreateRibbonPanel ( _ panelName As String _ ) As RibbonPanel |
Visual C++ |
---|
public: virtual RibbonPanel^ CreateRibbonPanel( String^ panelName ) |
Parameters
- panelName
- Type: System..::..String
The name of the panel to be created.
Remarks
This method will create a custom panel appending to the Revit AddIns tab. This method is not supported in Macros.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | panelName is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | panelName is Empty. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | If more than 100 panels were created. |