Set deformed shape settings object for the style.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void SetDeformedShapeSettings( AnalysisDisplayDeformedShapeSettings deformedShapeSettings ) |
Visual Basic |
---|
Public Sub SetDeformedShapeSettings ( _ deformedShapeSettings As AnalysisDisplayDeformedShapeSettings _ ) |
Visual C++ |
---|
public: void SetDeformedShapeSettings( AnalysisDisplayDeformedShapeSettings^ deformedShapeSettings ) |
Parameters
- deformedShapeSettings
- Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayDeformedShapeSettings
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Deformed shape settings were not created with the object. |