Copies all values from other element to this object.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void CopyFrom( Document OtherADoc, PanelScheduleTemplate otherElem ) |
Visual Basic |
---|
Public Sub CopyFrom ( _ OtherADoc As Document, _ otherElem As PanelScheduleTemplate _ ) |
Visual C++ |
---|
public: void CopyFrom( Document^ OtherADoc, PanelScheduleTemplate^ otherElem ) |
Parameters
- OtherADoc
- Type: Autodesk.Revit.DB..::..Document
The Document for the otherElem
- otherElem
- Type: Autodesk.Revit.DB.Electrical..::..PanelScheduleTemplate
The element being copied from.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The given template otherElem has different type of this element. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |