The id of the profile of the treads.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2013

Syntax

C#
public ElementId TreadProfile { get; set; }
Visual Basic
Public Property TreadProfile As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ TreadProfile {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException When setting this property: The profile is neither a valid element id nor invalidElementId. -or- When setting this property: The profile is not a valid tread profile symbol.
Autodesk.Revit.Exceptions..::..ArgumentNullException When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException When setting this property: The run type has no tread so the data being set is not applicable.

See Also