True if these results are part of a link cycle.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public bool IsCircularLink { get; } |
Visual Basic |
---|
Public ReadOnly Property IsCircularLink As Boolean Get |
Visual C++ |
---|
public: property bool IsCircularLink { bool get (); } |
Remarks
A link cycle occurs when, for example, model A links model B as an attachment,
which links model C as an attachment, which links model A as an attachment.
Revit will only load one copy of model A; it will ignore the instance of A linked
under C.
Circular links do not abort the load process, so they do not appear as a result type
in LinkLoadResultType.Enum.
This property is only relevant for LinkLoadResult object for RvtLinkSymbol.
ie. when getIsRvtLink() is true.