Indicates if "shading surfaces" are included in GreenBuildingXML export of the detailed model.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public bool IsExportShadingSurfacesEnabled { get; } |
Visual Basic |
---|
Public ReadOnly Property IsExportShadingSurfacesEnabled As Boolean Get |
Visual C++ |
---|
public: property bool IsExportShadingSurfacesEnabled { bool get (); } |
Remarks
Result is based on the ExportComplexity setting.
The method described by gbs/gbxml.org to calculate the shading surfaces is to
take all surfaces from the MEP spaces, subtract them from the surfaces from all building elements,
and then the remaining surfaces are considered to be the shading surfaces.