This class represents a triangle or quadrilateral in a faceted structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2013

Syntax

C#
public class TriOrQuadFacet : IDisposable
Visual Basic
Public Class TriOrQuadFacet _
	Implements IDisposable
Visual C++
public ref class TriOrQuadFacet : IDisposable

Remarks

This class defines a triangle or quadrilateral with reference to an external triangulation structure. The vertices of this TriOrQuadFacet are indices into the triangulation structure's array of vertices.

Inheritance Hierarchy

System..::..Object
  Autodesk.Revit.DB..::..TriOrQuadFacet

See Also