Returns all FabricArea elements hosted by the referenced element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public IList<FabricArea> GetFabricAreasInHost() |
Visual Basic |
---|
Public Function GetFabricAreasInHost As IList(Of FabricArea) |
Visual C++ |
---|
public: IList<FabricArea^>^ GetFabricAreasInHost() |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural. |