The type element associated with a DirectShape element. This element includes data reused by DirectShape elements of the same type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public class DirectShapeType : ElementType |
Visual Basic |
---|
Public Class DirectShapeType _ Inherits ElementType |
Visual C++ |
---|
public ref class DirectShapeType : public ElementType |
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..DirectShapeType
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..DirectShapeType