Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type,
demand factor, wire type in the Autodesk Revit application and project.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public ElectricalSetting ElectricalSetting { get; } |
Visual Basic |
---|
Public ReadOnly Property ElectricalSetting As ElectricalSetting Get |
Visual C++ |
---|
public: property ElectricalSetting^ ElectricalSetting { ElectricalSetting^ get (); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Electrical settings can be accessed only if Revit MEP product is available. |