Adds FamilySizeTableManager to a Family. A FamilySizeTableManager and FamilySizeTables are only needed when importing, exporting, or removing size data previously stored in CSV files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2014

Syntax

C#
public static bool CreateFamilySizeTableManager(
	Document document,
	ElementId familyId
)
Visual Basic
Public Shared Function CreateFamilySizeTableManager ( _
	document As Document, _
	familyId As ElementId _
) As Boolean
Visual C++
public:
static bool CreateFamilySizeTableManager(
	Document^ document, 
	ElementId^ familyId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Family owned document or project document.
familyId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the Family.

Return Value

True if successful, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also