Retrieves the GUID representing this document in exported gbXML files.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static Guid GetGBXMLDocumentId( Document document ) |
Visual Basic |
---|
Public Shared Function GetGBXMLDocumentId ( _ document As Document _ ) As Guid |
Visual C++ |
---|
public: static Guid GetGBXMLDocumentId( Document^ document ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document.
Return Value
The value of the GUID representing this document in gbXML export.
Remarks
This id can be used to cross-reference different gbXML exports from the same document.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |