An enumerated type containing possible constraint types for Adaptive Points.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public enum AdaptivePointConstraintType |
Visual Basic |
---|
Public Enumeration AdaptivePointConstraintType |
Visual C++ |
---|
public enum class AdaptivePointConstraintType |
Members
Member name | Description |
---|---|
None | Not constrained. |
Plane_YZ | Constrained to the YZ Plane (x=0). |
Plane_ZX | Constrained to the ZX Plane (y=0). |
Plane_XY | Constrained to the XY Plane (z=0). |
Axis_X | Constrained to the X Axis (y=0, z=0). |
Axis_Y | Constrained to the Y Axis (x=0, z=0). |
Axis_Z | Constrained to the Z Axis (x=0, y=0). |