Determine if this frame's basis is right-handed.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public bool IsRightHanded() |
Visual Basic |
---|
Public Function IsRightHanded As Boolean |
Visual C++ |
---|
public: bool IsRightHanded() |
Return Value
True if this frame's basis is right-handed, false if not.
Remarks
The three basis vectors are "right-handed" if the triple vector product [vecX, vecY, vecZ]
is positive, or equivalently if dot(vecX x vecY, vecZ) is positive, where "dot" represents the dot product.